CVE-2021-22876

NameCVE-2021-22876
Descriptioncurl 7.1.1 to and including 7.75.0 is vulnerable to an "Exposure of Private Personal Information to an Unauthorized Actor" by leaking credentials in the HTTP Referer: header. libcurl does not strip off user credentials from the URL when automatically populating the Referer: HTTP request header field in outgoing HTTP requests, and therefore risks leaking sensitive data to the server that is the target of the second HTTP request.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2664-1, DSA-4881-1
NVD severitymedium
Debian Bugs986269

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
curl (PTS)stretch7.52.1-5+deb9u10vulnerable
stretch (security)7.52.1-5+deb9u15fixed
buster, buster (security)7.64.0-4+deb10u2fixed
bookworm, bullseye, sid7.74.0-1.3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
curlsourcestretch7.52.1-5+deb9u14DLA-2664-1
curlsourcebuster7.64.0-4+deb10u2DSA-4881-1
curlsource(unstable)7.74.0-1.2986269

Notes

https://curl.se/docs/CVE-2021-22876.html
Fixed by: https://github.com/curl/curl/commit/7214288898f5625a6cc196e22a74232eada7861c

Search for package or bug name: Reporting problems