CVE-2021-22895

NameCVE-2021-22895
DescriptionNextcloud Desktop Client before 3.3.1 is vulnerable to improper certificate validation due to lack of SSL certificate verification when using the "Register with a Provider" flow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4974-1
NVD severitymedium
Debian Bugs989846

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nextcloud-desktop (PTS)buster, buster (security)2.5.1-3+deb10u2fixed
bullseye (security), bullseye3.1.1-2+deb11u1fixed
bookworm, sid3.3.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nextcloud-desktopsourcebuster2.5.1-3+deb10u2DSA-4974-1
nextcloud-desktopsourcebullseye3.1.1-2+deb11u1DSA-4974-1
nextcloud-desktopsource(unstable)3.3.1-1989846

Notes

https://github.com/nextcloud/desktop/pull/2926
https://github.com/nextcloud/desktop/commit/b1ddd0e491b2af0ed040e658d8bcde2a7a61c9fc (stable-3.1)
https://github.com/nextcloud/security-advisories/security/advisories/GHSA-qpgp-vf4p-wcw5

Search for package or bug name: Reporting problems