CVE-2021-22940

NameCVE-2021-22940
DescriptionNode.js before 16.6.1, 14.17.5, and 12.22.5 is vulnerable to a use after free attack where an attacker might be able to exploit the memory corruption, to change process behavior.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nodejs (PTS)stretch4.8.2~dfsg-1fixed
buster, buster (security)10.24.0~dfsg-1~deb10u1fixed
bullseye12.21.0~dfsg-5fixed
bullseye (security)12.22.5~dfsg-2~11u1fixed
bookworm12.22.5~dfsg-2fixed
sid12.22.5~dfsg-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nodejssourcestretch(not affected)
nodejssourcebuster(not affected)
nodejssourcebullseye(not affected)
nodejssource(unstable)12.22.5~dfsg-1

Notes

[bullseye] - nodejs <not-affected> (Incomplete fix for CVE-2021-22930 not applied)
[buster] - nodejs <not-affected> (Incomplete fix for CVE-2021-22930 not applied)
[stretch] - nodejs <not-affected> (Incomplete fix for CVE-2021-22930 not applied)
https://nodejs.org/en/blog/vulnerability/aug-2021-security-releases/#use-after-free-on-close-http2-on-stream-canceling-high-cve-2021-22940

Search for package or bug name: Reporting problems