CVE-2021-22942

NameCVE-2021-22942
DescriptionA possible open redirect vulnerability in the Host Authorization middleware in Action Pack >= 6.0.0 that could allow attackers to redirect users to a malicious website.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs992586

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rails (PTS)buster2:5.2.2.1+dfsg-1+deb10u3fixed
buster (security)2:5.2.2.1+dfsg-1+deb10u5fixed
bullseye2:6.0.3.7+dfsg-2vulnerable
bookworm, sid2:6.1.7+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
railssourceexperimental2:6.1.4.1+dfsg-1
railssourcestretch(not affected)
railssourcebuster(not affected)
railssource(unstable)2:6.1.4.1+dfsg-3992586

Notes

[bullseye] - rails <no-dsa> (Minor issue)
[buster] - rails <not-affected> (Vulnerable code not present)
[stretch] - rails <not-affected> (Vulnerable code not present)
https://www.openwall.com/lists/oss-security/2021/08/20/1

Search for package or bug name: Reporting problems