CVE-2021-23017

NameCVE-2021-23017
DescriptionA security issue in nginx resolver was identified, which might allow an attacker who is able to forge UDP packets from the DNS server to cause 1-byte memory overwrite, resulting in worker process crash or potential other impact.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2670-1, DSA-4921-1
NVD severityhigh
Debian Bugs989095

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nginx (PTS)stretch1.10.3-1+deb9u4vulnerable
stretch (security)1.10.3-1+deb9u7fixed
buster, buster (security)1.14.2-2+deb10u4fixed
bullseye, sid1.18.0-6.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nginxsourcestretch1.10.3-1+deb9u6DLA-2670-1
nginxsourcebuster1.14.2-2+deb10u4DSA-4921-1
nginxsource(unstable)1.18.0-6.1989095

Notes

https://www.openwall.com/lists/oss-security/2021/05/25/5
Patch: http://nginx.org/download/patch.2021.resolver.txt
Fixed by: https://github.com/nginx/nginx/commit/7199ebc203f74fd9e44595474de6bdc41740c5cf (1.20.1)

Search for package or bug name: Reporting problems