CVE-2021-23159

NameCVE-2021-23159
DescriptionA vulnerability was found in SoX, where a heap-buffer-overflow occurs in function lsx_read_w_buf() in formats_i.c file. The vulnerability is exploitable with a crafted file, that could cause an application to crash.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1021133

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
sox (PTS)buster14.4.2+git20190427-1vulnerable
bullseye14.4.2+git20190427-2vulnerable
bookworm, sid14.4.2+git20190427-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
soxsource(unstable)(unfixed)1021133

Notes

https://bugzilla.redhat.com/show_bug.cgi?id=1975671
https://sourceforge.net/p/sox/bugs/352/

Search for package or bug name: Reporting problems