CVE-2021-23337

NameCVE-2021-23337
DescriptionLodash versions prior to 4.17.21 are vulnerable to Command Injection via the template function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs985086

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-lodash (PTS)stretch4.16.6+dfsg-2vulnerable
buster4.17.11+dfsg-2+deb10u1vulnerable
bullseye, sid4.17.21+dfsg+~cs8.31.173-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-lodashsourcestretch(unfixed)end-of-life
node-lodashsource(unstable)4.17.21+dfsg+~cs8.31.173-1985086

Notes

[buster] - node-lodash <no-dsa> (Minor issue)
[stretch] - node-lodash <end-of-life> (Nodejs in stretch not covered by security support)
https://snyk.io/vuln/SNYK-JS-LODASH-1040724

Search for package or bug name: Reporting problems