CVE-2021-23369

NameCVE-2021-23369
DescriptionThe package handlebars before 4.7.7 are vulnerable to Remote Code Execution (RCE) when selecting certain compiling options to compile templates coming from an untrusted source.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libjs-handlebars (PTS)stretch3:4.0.5-4vulnerable
node-handlebars (PTS)buster3:4.1.0-1+deb10u3fixed
bookworm, sid, bullseye3:4.7.6+~4.1.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libjs-handlebarssource(unstable)(unfixed)
node-handlebarssourcebuster3:4.1.0-1+deb10u3
node-handlebarssource(unstable)3:4.7.6+~4.1.0-2

Notes

[stretch] - libjs-handlebars <ignored> (Minor issue and too intrusive to backport)
https://github.com/handlebars-lang/handlebars.js/commit/b6d3de7123eebba603e321f04afdbae608e8fea8
https://github.com/handlebars-lang/handlebars.js/commit/f0589701698268578199be25285b2ebea1c1e427
https://snyk.io/vuln/SNYK-JS-HANDLEBARS-1056767

Search for package or bug name: Reporting problems