CVE-2021-23383

NameCVE-2021-23383
DescriptionThe package handlebars before 4.7.7 are vulnerable to Prototype Pollution when selecting certain compiling options to compile templates coming from an untrusted source.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libjs-handlebars (PTS)stretch3:4.0.5-4vulnerable
node-handlebars (PTS)buster3:4.1.0-1+deb10u3vulnerable
bullseye, sid3:4.7.6+~4.1.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libjs-handlebarssource(unstable)(unfixed)
node-handlebarssource(unstable)3:4.7.6+~4.1.0-2

Notes

[buster] - node-handlebars <no-dsa> (Minor issue; can be fixed via point release)
[stretch] - libjs-handlebars <postponed> (Minor issue; can be fixed in next update)
https://github.com/handlebars-lang/handlebars.js/commit/f0589701698268578199be25285b2ebea1c1e427
https://snyk.io/vuln/SNYK-JS-HANDLEBARS-1279029

Search for package or bug name: Reporting problems