CVE-2021-23409

NameCVE-2021-23409
DescriptionThe package github.com/pires/go-proxyproto before 0.6.0 are vulnerable to Denial of Service (DoS) via creating connections without the proxy protocol header.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs991498

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
golang-github-pires-go-proxyproto (PTS)bookworm, sid, bullseye0.4.2-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
golang-github-pires-go-proxyprotosource(unstable)(unfixed)991498

Notes

[bullseye] - golang-github-pires-go-proxyproto <no-dsa> (Minor issue)
https://github.com/pires/go-proxyproto/issues/65
https://snyk.io/vuln/SNYK-GOLANG-GITHUBCOMPIRESGOPROXYPROTO-1316439
https://github.com/pires/go-proxyproto/pull/74

Search for package or bug name: Reporting problems