CVE-2021-23437

NameCVE-2021-23437
DescriptionThe package pillow 5.2.0 and before 8.3.2 are vulnerable to Regular Expression Denial of Service (ReDoS) via the getrgb function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pillow (PTS)buster, buster (security)5.4.1-2+deb10u3vulnerable
bullseye (security), bullseye8.1.2+dfsg-0.3+deb11u1vulnerable
bookworm, sid9.2.0-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pillowsource(unstable)8.3.2-1

Notes

[bullseye] - pillow <no-dsa> (Minor issue)
[buster] - pillow <no-dsa> (Minor issue)
[stretch] - pillow <postponed> (Minor issue, can be fixed in the next DLA)
https://github.com/python-pillow/Pillow/commit/9e08eb8f78fdfd2f476e1b20b7cf38683754866b
https://snyk.io/vuln/SNYK-PYTHON-PILLOW-1319443

Search for package or bug name: Reporting problems