DescriptionThe package @braintree/sanitize-url before 6.0.0 are vulnerable to Cross-site Scripting (XSS) due to improper sanitization in sanitizeUrl function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-mermaid (PTS)bullseye8.7.0+ds+~cs27.17.17-3vulnerable
bookworm, sid8.14.0+~cs11.4.14-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


[bullseye] - node-mermaid <no-dsa> (Minor issue)
src:node-mermaid provides embedded @braintree/sanitize-url

Search for package or bug name: Reporting problems