CVE-2021-23792

NameCVE-2021-23792
DescriptionThe package com.twelvemonkeys.imageio:imageio-metadata before 3.7.1 are vulnerable to XML External Entity (XXE) Injection due to an insecurely initialized XML parser for reading XMP Metadata. An attacker can exploit this vulnerability if they are able to supply a file (e.g. when an online profile picture is processed) with a malicious XMP segment. If the XMP metadata of the uploaded image is parsed, then the XXE vulnerability is triggered.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libtwelvemonkeys-java (PTS)buster3.4.1-1vulnerable
bullseye3.6.3-1vulnerable
bookworm, sid3.9.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libtwelvemonkeys-javasource(unstable)3.8.0-1

Notes

[bullseye] - libtwelvemonkeys-java <no-dsa> (Minor issue)
[buster] - libtwelvemonkeys-java <no-dsa> (Minor issue)
https://snyk.io/vuln/SNYK-JAVA-COMTWELVEMONKEYSIMAGEIO-2316763
https://github.com/haraldk/TwelveMonkeys/commit/da4efe98bf09e1cce91b7633cb251958a200fc80 (twelvemonkeys-3.8.0)

Search for package or bug name: Reporting problems