CVE-2021-23991

NameCVE-2021-23991
DescriptionIf a Thunderbird user has previously imported Alice's OpenPGP key, and Alice has extended the validity period of her key, but Alice's updated key has not yet been imported, an attacker may send an email containing a crafted version of Alice's key with an invalid subkey, Thunderbird might subsequently attempt to use the invalid subkey, and will fail to send encrypted email to Alice. This vulnerability affects Thunderbird < 78.9.1.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2632-1, DSA-4897-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
thunderbird (PTS)stretch1:68.10.0-1~deb9u1vulnerable
stretch (security)1:78.14.0-1~deb9u1fixed
buster, buster (security)1:78.14.0-1~deb10u1fixed
bullseye (security), bullseye1:78.14.0-1~deb11u1fixed
bookworm1:78.14.0-1fixed
sid1:91.2.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
thunderbirdsourcestretch1:78.10.0-1~deb9u1DLA-2632-1
thunderbirdsourcebuster1:78.10.0-1~deb10u1DSA-4897-1
thunderbirdsource(unstable)1:78.10.0-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2021-13/#CVE-2021-23991

Search for package or bug name: Reporting problems