CVE-2021-24115

NameCVE-2021-24115
DescriptionIn Botan before 2.17.3, constant-time computations are not used for certain decoding and encoding operations (base32, base58, base64, and hex).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
botan (PTS)buster2.9.0-2vulnerable
bullseye2.17.3+dfsg-2fixed
sid2.17.3+dfsg-3fixed
botan1.10 (PTS)stretch1.10.16-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
botansource(unstable)2.17.3+dfsg-1
botan1.10sourcestretch(not affected)
botan1.10source(unstable)(unfixed)

Notes

[buster] - botan <no-dsa> (Minor issue)
[stretch] - botan1.10 <not-affected> (Vulnerable code not present)
https://github.com/randombit/botan/pull/2549

Search for package or bug name: Reporting problems