CVE-2021-25287

NameCVE-2021-25287
DescriptionAn issue was discovered in Pillow before 8.2.0. There is an out-of-bounds read in J2kDecode, in j2ku_graya_la.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs989062

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pillow (PTS)stretch4.0.0-4+deb9u1vulnerable
stretch (security)4.0.0-4+deb9u3vulnerable
buster5.4.1-2+deb10u2vulnerable
buster (security)5.4.1-2+deb10u1vulnerable
bookworm, bullseye8.1.2+dfsg-0.3fixed
sid8.1.2+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pillowsourceexperimental8.2.0-1
pillowsource(unstable)8.1.2+dfsg-0.2unimportant989062

Notes

https://pillow.readthedocs.io/en/stable/releasenotes/8.2.0.html#cve-2021-25287-cve-2021-25288-fix-oob-read-in-jpeg2kdecode
https://github.com/python-pillow/Pillow/commit/3bf5eddb89afdf690eceaa52bc4d3546ba9a5f87
Debian packages are built without JPEG2000 support

Search for package or bug name: Reporting problems