CVE-2021-26271

NameCVE-2021-26271
DescriptionIt was possible to execute a ReDoS-type attack inside CKEditor 4 before 4.16 by persuading a victim to paste crafted text into the Styles input of specific dialogs (in the Advanced Tab for Dialogs plugin).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs982587

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ckeditor (PTS)stretch4.5.7+dfsg-2vulnerable
stretch (security)4.5.7+dfsg-2+deb9u1vulnerable
buster4.11.1+dfsg-1vulnerable
bullseye4.16.0+dfsg-2fixed
bookworm, sid4.16.2+dfsg-1fixed
ckeditor3 (PTS)stretch3.6.6.1+dfsg-1vulnerable
buster3.6.6.1+dfsg-3vulnerable
bookworm, sid, bullseye3.6.6.1+dfsg-7vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ckeditorsource(unstable)4.16.0+dfsg-1982587
ckeditor3sourcestretch(unfixed)end-of-life
ckeditor3source(unstable)(unfixed)

Notes

[buster] - ckeditor <no-dsa> (Minor issue)
[stretch] - ckeditor <postponed> (Fix along next DLA)
[stretch] - ckeditor3 <end-of-life> (EOL'd for stretch)
https://github.com/ckeditor/ckeditor4/blob/major/CHANGES.md#ckeditor-416

Search for package or bug name: Reporting problems