CVE-2021-26272

NameCVE-2021-26272
DescriptionIt was possible to execute a ReDoS-type attack inside CKEditor 4 before 4.16 by persuading a victim to paste crafted URL-like text into the editor, and then press Enter or Space (in the Autolink plugin).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs982587

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ckeditor (PTS)stretch4.5.7+dfsg-2vulnerable
buster4.11.1+dfsg-1vulnerable
bullseye, sid4.12.1+dfsg-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ckeditorsource(unstable)(unfixed)982587

Notes

[stretch] - ckeditor <postponed> (Fix along next DLA)
https://github.com/ckeditor/ckeditor4/blob/major/CHANGES.md#ckeditor-416

Search for package or bug name: Reporting problems