CVE-2021-26906

NameCVE-2021-26906
DescriptionAn issue was discovered in res_pjsip_session.c in Digium Asterisk through 13.38.1; 14.x, 15.x, and 16.x through 16.16.0; 17.x through 17.9.1; and 18.x through 18.2.0, and Certified Asterisk through 16.8-cert5. An SDP negotiation vulnerability in PJSIP allows a remote server to potentially crash Asterisk by sending specific SIP responses that cause an SDP negotiation failure.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs983159

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
asterisk (PTS)buster1:16.2.1~dfsg-1+deb10u2vulnerable
buster (security)1:16.28.0~dfsg-0+deb10u1fixed
bullseye1:16.16.1~dfsg-1+deb11u1fixed
bullseye (security)1:16.28.0~dfsg-0+deb11u1fixed
bookworm, sid1:20.0.0~dfsg+~cs6.12.40431414-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
asterisksource(unstable)1:16.16.1~dfsg-1983159

Notes

[buster] - asterisk <postponed> (Minor issue)
[stretch] - asterisk <no-dsa> (Minor issue)
https://downloads.asterisk.org/pub/security/AST-2021-005.html
https://issues.asterisk.org/jira/browse/ASTERISK-29196

Search for package or bug name: Reporting problems