CVE-2021-26932

NameCVE-2021-26932
DescriptionAn issue was discovered in the Linux kernel 3.2 through 5.10.16, as used by Xen. Grant mapping operations often occur in batch hypercalls, where a number of operations are done in a single hypercall, the success or failure of each one is reported to the backend driver, and the backend driver then loops over the results, performing follow-up actions based on the success or failure of each operation. Unfortunately, when running in PV mode, the Linux backend drivers mishandle this: Some errors are ignored, effectively implying their success from the success of related batch elements. In other cases, errors resulting from one batch element lead to further batch elements not being inspected, and hence successful ones to not be possible to properly unmap upon error recovery. Only systems with Linux backends running in PV mode are vulnerable. Linux backends run in HVM / PVH modes are not vulnerable. This affects arch/*/xen/p2m.c and drivers/xen/gntdev.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2586-1, DLA-2610-1
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)stretch4.9.228-1vulnerable
stretch (security)4.9.272-2fixed
buster4.19.194-1fixed
buster (security)4.19.194-3fixed
bullseye (security)5.10.46-5fixed
bookworm, bullseye5.10.46-4fixed
sid5.14.6-2fixed
linux-4.19 (PTS)stretch (security)4.19.194-3~deb9u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcestretch4.9.258-1DLA-2586-1
linuxsourcebuster4.19.177-1
linuxsource(unstable)5.10.19-1
linux-4.19sourcestretch4.19.181-1~deb9u1DLA-2610-1

Notes

https://xenbits.xen.org/xsa/advisory-361.html

Search for package or bug name: Reporting problems