CVE-2021-26934

NameCVE-2021-26934
DescriptionAn issue was discovered in the Linux kernel 4.18 through 5.10.16, as used by Xen. The backend allocation (aka be-alloc) mode of the drm_xen_front drivers was not meant to be a supported configuration, but this wasn't stated accordingly in its support status entry.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)stretch4.9.228-1fixed
stretch (security)4.9.258-1fixed
buster4.19.181-1vulnerable
buster (security)4.19.171-2vulnerable
bullseye, sid5.10.28-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcestretch(not affected)
linuxsource(unstable)(unfixed)unimportant

Notes

[stretch] - linux <not-affected> (Vulnerable code not present)
https://xenbits.xen.org/xsa/advisory-363.html
Driver never was meant to be supported and the patch in src:xen will only
update SUPPORT.md to explicitly document the fact.

Search for package or bug name: Reporting problems