CVE-2021-26945

NameCVE-2021-26945
DescriptionAn integer overflow leading to a heap-buffer overflow was found in OpenEXR in versions before 3.0.1. An attacker could use this flaw to crash an application compiled with OpenEXR.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openexr (PTS)stretch2.2.0-11vulnerable
stretch (security)2.2.0-11+deb9u4vulnerable
buster, buster (security)2.2.1-4.1+deb10u1vulnerable
bullseye2.5.4-2vulnerable
bookworm, sid2.5.7-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openexrsource(unstable)(unfixed)unimportant

Notes

https://bugzilla.redhat.com/show_bug.cgi?id=1947591
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=31221
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=31228
https://github.com/AcademySoftwareFoundation/openexr/pull/930
https://github.com/AcademySoftwareFoundation/openexr/commit/2f01a253db2bc82724405a16c76783c38c67ba05
Only affects exrcheck, which isn't built into the binary packages

Search for package or bug name: Reporting problems