DescriptionA flaw was discovered in Puppet Agent and Puppet Server that may result in a leak of HTTP credentials when following HTTP redirects to a different host. This is similar to CVE-2018-1000007
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
puppet (PTS)buster5.5.10-4vulnerable
puppet-agent (PTS)sid, trixie, bookworm7.23.0-1fixed
puppetserver (PTS)sid, bookworm7.9.5-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
puppet-agentsource(unstable)(not affected)
puppetserversource(unstable)(not affected)


[bullseye] - puppet <ignored> (Minor issue)
[buster] - puppet <ignored> (Minor issue)
[stretch] - puppet <ignored> (Minor issue)
- puppet-agent <not-affected> (Fixed before initial release, in 6.25.1)
- puppetserver <not-affected> (Fixed before initial release, in 7.4.2) (6.25.1)
Marginal/unclear security implications, the redirects are fully under control of
the puppet masters and the advisory states this CVE would be similar to CVE-2018-1000007,
but CVE is for curl, which obviously has different scope being a library. Plus, all
reasonably secure installations use client auth on the agents
Previous client code in lib/puppet/network/http/connection.rb also vulnerable

Search for package or bug name: Reporting problems