CVE-2021-27097

NameCVE-2021-27097
DescriptionThe boot loader in Das U-Boot before 2021.04-rc2 mishandles a modified FIT.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs983270

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
u-boot (PTS)stretch2016.11+dfsg1-4vulnerable
buster2019.01+dfsg-7vulnerable
bullseye2021.01+dfsg-2vulnerable
sid2021.01+dfsg-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
u-bootsource(unstable)(unfixed)983270

Notes

[buster] - u-boot <no-dsa> (Minor issue)
[stretch] - u-boot <postponed> (Minor issue; can be fixed in next DLA)
https://github.com/u-boot/u-boot/commit/6f3c2d8aa5e6cbd80b5e869bbbddecb66c329d01
https://github.com/u-boot/u-boot/commit/8a7d4cf9820ea16fabd25a6379351b4dc291204b
https://github.com/u-boot/u-boot/commit/b6f4c757959f8850e1299a77c8e5713da78e8ec0

Search for package or bug name: Reporting problems