CVE-2021-27922

NameCVE-2021-27922
DescriptionPillow before 8.1.1 allows attackers to cause a denial of service (memory consumption) because the reported size of a contained image is not properly checked for an ICNS container, and thus an attempted memory allocation can be very large.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pillow (PTS)stretch4.0.0-4+deb9u1vulnerable
stretch (security)4.0.0-4+deb9u4vulnerable
buster, buster (security)5.4.1-2+deb10u3fixed
bullseye (security), bullseye8.1.2+dfsg-0.3+deb11u1fixed
bookworm9.0.1-1fixed
sid9.1.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pillowsourcebuster5.4.1-2+deb10u3
pillowsource(unstable)8.1.2-1

Notes

[stretch] - pillow <ignored> (Minor issue, risk of regression, _decompression_bomb_check only warned, see CVE-2019-16865)
https://pillow.readthedocs.io/en/stable/releasenotes/8.1.2.html
https://github.com/python-pillow/Pillow/commit/756fff33128a0b643d10518a26ad04b726dd8973

Search for package or bug name: Reporting problems