CVE-2021-27927

NameCVE-2021-27927
DescriptionIn Zabbix from 4.0.x before 4.0.28rc1, 5.0.0alpha1 before 5.0.10rc1, 5.2.x before 5.2.6rc1, and 5.4.0alpha1 before 5.4.0beta2, the CControllerAuthenticationUpdate controller lacks a CSRF protection mechanism. The code inside this controller calls diableSIDValidation inside the init() method. An attacker doesn't have to know Zabbix user login credentials, but has to know the correct Zabbix URL and contact information of an existing user with sufficient privileges.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
zabbix (PTS)stretch1:3.0.7+dfsg-3vulnerable
stretch (security)1:3.0.31+dfsg-0+deb9u1vulnerable
buster1:4.0.4+dfsg-1vulnerable
bullseye, sid1:5.0.8+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
zabbixsource(unstable)1:5.0.8+dfsg-1

Notes

[buster] - zabbix <no-dsa> (Minor issue)
[stretch] - zabbix <no-dsa> (minor issue)
https://support.zabbix.com/browse/ZBX-18942

Search for package or bug name: Reporting problems