CVE-2021-28041

NameCVE-2021-28041
Descriptionssh-agent in OpenSSH before 8.5 has a double free that may be relevant in a few less-common scenarios, such as unconstrained agent-socket access on a legacy operating system, or the forwarding of an agent to an attacker-controlled host.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs984940

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openssh (PTS)buster1:7.9p1-10+deb10u2fixed
buster (security)1:7.9p1-10+deb10u3fixed
bullseye1:8.4p1-5+deb11u2fixed
bookworm1:9.2p1-2+deb12u1fixed
trixie1:9.4p1-1fixed
sid1:9.5p1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensshsourcestretch(not affected)
opensshsourcebuster(not affected)
opensshsource(unstable)1:8.4p1-5984940

Notes

[buster] - openssh <not-affected> (Vulnerable code introduced later)
[stretch] - openssh <not-affected> (Vulnerable code introduced later)
https://www.openwall.com/lists/oss-security/2021/03/03/1
https://github.com/openssh/openssh-portable/commit/e04fd6dde16de1cdc5a4d9946397ff60d96568db
https://ftp.openbsd.org/pub/OpenBSD/patches/6.8/common/015_sshagent.patch.sig

Search for package or bug name: Reporting problems