CVE-2021-28090

NameCVE-2021-28090
DescriptionTor before 0.4.5.7 allows a remote attacker to cause Tor directory authorities to exit with an assertion failure, aka TROVE-2021-002.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4871-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tor (PTS)stretch0.2.9.16-1vulnerable
stretch (security)0.2.9.15-1vulnerable
buster, buster (security)0.3.5.16-1fixed
bullseye (security), bullseye0.4.5.10-1~deb11u1fixed
bookworm, sid0.4.5.10-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
torsourcestretch(unfixed)end-of-life
torsourcebuster0.3.5.14-1DSA-4871-1
torsource(unstable)0.4.5.7-1

Notes

[stretch] - tor <end-of-life> (See DSA 4644)
https://blog.torproject.org/node/2009
https://bugs.torproject.org/tpo/core/tor/40316

Search for package or bug name: Reporting problems