CVE-2021-28091

NameCVE-2021-28091
DescriptionLasso all versions prior to 2.7.0 has improper verification of a cryptographic signature.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2684-1, DSA-4926-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lasso (PTS)stretch2.5.0-5vulnerable
stretch (security)2.5.0-5+deb9u1fixed
buster2.6.0-2vulnerable
buster (security)2.6.0-2+deb10u1fixed
bullseye, sid2.6.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lassosourcestretch2.5.0-5+deb9u1DLA-2684-1
lassosourcebuster2.6.0-2+deb10u1DSA-4926-1
lassosource(unstable)2.6.1-3

Notes

https://bugzilla.redhat.com/show_bug.cgi?id=1940089
https://blogs.akamai.com/2021/06/saml-implementation-vulnerability-impacting-some-akamai-services.html
https://blogs.akamai.com/2021/06/akamai-eaa-impersonation-vulnerability---a-deep-dive.html
https://git.entrouvert.org/lasso.git/commit/?id=ea7e5efe9741e1b1787a58af16cb15b40c23be5a

Search for package or bug name: Reporting problems