CVE-2021-28116

NameCVE-2021-28116
DescriptionSquid through 4.14 and 5.x through 5.0.5, in some configurations, allows information disclosure because of an out-of-bounds read in WCCP protocol data. This can be leveraged as part of a chain for remote code execution as nobody.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-5171-1
Debian Bugs986804

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
squid (PTS)buster4.6-1+deb10u6vulnerable
buster (security)4.6-1+deb10u7fixed
bullseye4.13-10vulnerable
bullseye (security)4.13-10+deb11u1fixed
bookworm, sid5.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
squidsourcebuster4.6-1+deb10u7DSA-5171-1
squidsourcebullseye4.13-10+deb11u1DSA-5171-1
squidsource(unstable)5.2-1986804
squid3source(unstable)(unfixed)

Notes

[stretch] - squid3 <postponed> (Check later when information is public)
https://www.zerodayinitiative.com/advisories/ZDI-CAN-11610/
https://bugs.squid-cache.org/show_bug.cgi?id=5131
https://www.openwall.com/lists/oss-security/2021/10/04/1
Squid4: http://www.squid-cache.org/Versions/v4/changesets/SQUID-2020_12.patch
Squid5: http://www.squid-cache.org/Versions/v5/changesets/squid-5-7a73a54cefff6bb83c03de219a73276e42d183d0.patch

Search for package or bug name: Reporting problems