CVE-2021-28156

NameCVE-2021-28156
DescriptionHashiCorp Consul Enterprise version 1.8.0 up to 1.9.4 audit log can be bypassed by specifically crafted HTTP events. Fixed in 1.9.5, and 1.8.10.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
consul (PTS)buster1.0.7~dfsg1-5fixed
bullseye1.8.7+dfsg1-2fixed
sid, bookworm1.8.7+dfsg1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
consulsource(unstable)(not affected)

Notes

- consul <not-affected> (Only affects Enterprise version)
https://bugzilla.redhat.com/show_bug.cgi?id=1950492
https://github.com/hashicorp/consul/pull/10030

Search for package or bug name: Reporting problems