CVE-2021-28302

NameCVE-2021-28302
DescriptionA stack overflow in pupnp before version 1.14.5 can cause the denial of service through the Parser_parseDocument() function. ixmlNode_free() will release a child node recursively, which will consume stack space and lead to a crash.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs986833

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pupnp (PTS)sid, trixie1:1.14.19-2fixed
pupnp-1.8 (PTS)buster, bookworm, bullseye1:1.8.4-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libupnpsource(unstable)(unfixed)
pupnpsource(unstable)(not affected)
pupnp-1.8source(unstable)(unfixed)986833

Notes

- pupnp <not-affected> (Fixed before initial upload to Debian after source package rename)
[bookworm] - pupnp-1.8 <no-dsa> (Minor issue)
[bullseye] - pupnp-1.8 <no-dsa> (Minor issue)
[buster] - pupnp-1.8 <no-dsa> (Minor issue)
[stretch] - libupnp <no-dsa> (Minor issue)
https://github.com/pupnp/pupnp/issues/249

Search for package or bug name: Reporting problems