CVE-2021-28700

NameCVE-2021-28700
Descriptionxen/arm: No memory limit for dom0less domUs The dom0less feature allows an administrator to create multiple unprivileged domains directly from Xen. Unfortunately, the memory limit from them is not set. This allow a domain to allocate memory beyond what an administrator originally configured.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4977-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)stretch (security), stretch4.8.5.final+shim4.10.4-1+deb9u12fixed
buster4.11.4+99-g8bce4698f6-1fixed
buster (security)4.11.4+107-gef32c7afa2-1fixed
bullseye4.14.2+25-gb6a8c4f72d-2vulnerable
bullseye (security)4.14.3-1~deb11u1fixed
bookworm, sid4.14.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensourcestretch(not affected)
xensourcebuster(not affected)
xensourcebullseye4.14.3-1~deb11u1DSA-4977-1
xensource(unstable)4.14.3-1

Notes

[buster] - xen <not-affected> (Only affects 4.12 and later)
[stretch] - xen <not-affected> (Only affects 4.12 and later)
https://xenbits.xen.org/xsa/advisory-383.html

Search for package or bug name: Reporting problems