CVE-2021-28703

NameCVE-2021-28703
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)stretch (security), stretch4.8.5.final+shim4.10.4-1+deb9u12vulnerable
buster, buster (security)4.11.4+107-gef32c7afa2-1vulnerable
bullseye4.14.3-1~deb11u1fixed
bullseye (security)4.14.3+32-g9de3671772-1~deb11u1fixed
bookworm, sid4.14.3+32-g9de3671772-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensourcestretch(unfixed)end-of-life
xensourcebuster(unfixed)end-of-life
xensource(unstable)4.14.0+80-gd101b417b7-1

Notes

[buster] - xen <end-of-life> (DSA 4677-1)
[stretch] - xen <end-of-life> (DSA 4602-1)
https://xenbits.xen.org/xsa/advisory-387.html
Fixed by code cleanup in Xen 4.14, and backported to security-supported Xen branches
as a prerequisite of the fix for XSA-378. 4.14.0-1~exp1 was the first version in
Debian including the fix.
https://xenbits.xen.org/gitweb/?p=xen.git;a=commit;h=c65ea16dbcafbe4fe21693b18f8c2a3c5d14600e (4.14.0-rc1)

Search for package or bug name: Reporting problems