CVE-2021-28706

NameCVE-2021-28706
Descriptionguests may exceed their designated memory limit When a guest is permitted to have close to 16TiB of memory, it may be able to issue hypercalls to increase its memory allocation beyond the administrator established limit. This is a result of a calculation done with 32-bit precision, which may overflow. It would then only be the overflowed (and hence small) number which gets compared against the established upper bound.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-5017-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)stretch (security), stretch4.8.5.final+shim4.10.4-1+deb9u12vulnerable
buster, buster (security)4.11.4+107-gef32c7afa2-1vulnerable
bullseye4.14.3-1~deb11u1vulnerable
bullseye (security)4.14.3+32-g9de3671772-1~deb11u1fixed
bookworm, sid4.14.3+32-g9de3671772-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensourcestretch(unfixed)end-of-life
xensourcebuster(unfixed)end-of-life
xensourcebullseye4.14.3+32-g9de3671772-1~deb11u1DSA-5017-1
xensource(unstable)4.14.3+32-g9de3671772-1

Notes

[buster] - xen <end-of-life> (DSA 4677-1)
[stretch] - xen <end-of-life> (DSA 4602-1)
https://xenbits.xen.org/xsa/advisory-385.html

Search for package or bug name: Reporting problems