CVE-2021-28876

NameCVE-2021-28876
DescriptionIn the standard library in Rust before 1.52.0, the Zip implementation has a panic safety issue. It calls __iterator_get_unchecked() more than once for the same index when the underlying iterator panics (in certain conditions). This bug could lead to a memory safety violation due to an unmet safety requirement for the TrustedRandomAccess trait.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs986803

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rustc (PTS)stretch1.34.2+dfsg1-1~deb9u1vulnerable
stretch (security)1.41.1+dfsg1-1~deb9u1vulnerable
buster1.41.1+dfsg1-1~deb10u1vulnerable
bullseye1.48.0+dfsg1-2vulnerable
bookworm1.50.0+dfsg1-1vulnerable
sid1.56.0+dfsg1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
rustcsource(unstable)1.53.0+dfsg1-1986803

Notes

[bullseye] - rustc <no-dsa> (Minor issue)
[buster] - rustc <no-dsa> (Minor issue)
[stretch] - rustc <no-dsa> (Minor issue)
https://github.com/rust-lang/rust/issues/81740
https://github.com/rust-lang/rust/pull/81741

Search for package or bug name: Reporting problems