CVE-2021-28965

NameCVE-2021-28965
DescriptionThe REXML gem before 3.2.5 in Ruby before 2.6.7, 2.7.x before 2.7.3, and 3.x before 3.0.1 does not properly address XML round-trip issues. An incorrect document can be produced after parsing and serializing.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs986806, 986807

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby-rexml (PTS)sid3.2.4-2vulnerable
ruby2.3 (PTS)stretch2.3.3-1+deb9u8vulnerable
stretch (security)2.3.3-1+deb9u9vulnerable
ruby2.5 (PTS)buster2.5.5-3+deb10u3vulnerable
buster (security)2.5.5-3+deb10u2vulnerable
ruby2.7 (PTS)bullseye, sid2.7.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby-rexmlsourceexperimental3.2.5-1
ruby-rexmlsource(unstable)(unfixed)986806
ruby2.3source(unstable)(unfixed)
ruby2.5source(unstable)(unfixed)
ruby2.7source(unstable)2.7.3-1986807

Notes

[buster] - ruby2.5 <postponed> (Minor issue, can be fixed along with next update)
[stretch] - ruby2.3 <postponed> (Minor issue; can be fixed in next update)
https://www.ruby-lang.org/en/news/2021/04/05/xml-round-trip-vulnerability-in-rexml-cve-2021-28965/

Search for package or bug name: Reporting problems