CVE-2021-28972

NameCVE-2021-28972
DescriptionIn drivers/pci/hotplug/rpadlpar_sysfs.c in the Linux kernel through 5.11.8, the RPA PCI Hotplug driver has a user-tolerable buffer overflow when writing a new device name to the driver from userspace, allowing userspace to write data to the kernel stack frame directly. This occurs because add_slot_store and remove_slot_store mishandle drc_name '\0' termination, aka CID-cc7a0bb058b8.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)stretch4.9.228-1vulnerable
stretch (security)4.9.258-1vulnerable
buster4.19.181-1vulnerable
buster (security)4.19.171-2vulnerable
bullseye, sid5.10.28-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)5.10.26-1

Notes

[stretch] - linux <ignored> (Driver is specific to IBM Power systems)
https://git.kernel.org/linus/cc7a0bb058b85ea03db87169c60c7cfdd5d34678

Search for package or bug name: Reporting problems