CVE-2021-29955

NameCVE-2021-29955
DescriptionA transient execution vulnerability, named Floating Point Value Injection (FPVI) allowed an attacker to leak arbitrary memory addresses and may have also enabled JIT type confusion attacks. (A related vulnerability, Speculative Code Store Bypass (SCSB), did not affect Firefox.). This vulnerability affects Firefox ESR < 78.9 and Firefox < 87.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2607-1, DSA-4874-1
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid92.0-1fixed
firefox-esr (PTS)stretch68.10.0esr-1~deb9u1vulnerable
stretch (security)78.14.0esr-1~deb9u1fixed
buster78.11.0esr-1~deb10u1fixed
buster (security)78.14.0esr-1~deb10u1fixed
bullseye78.12.0esr-1fixed
bullseye (security)78.14.0esr-1~deb11u1fixed
bookworm, sid78.14.0esr-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)87.0-1
firefox-esrsourcestretch78.9.0esr-1~deb9u1DLA-2607-1
firefox-esrsourcebuster78.9.0esr-1~deb10u1DSA-4874-1
firefox-esrsource(unstable)78.9.0esr-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2021-10/#CVE-2021-29955
https://www.mozilla.org/en-US/security/advisories/mfsa2021-11/#CVE-2021-29955

Search for package or bug name: Reporting problems