CVE-2021-30014

NameCVE-2021-30014
DescriptionThere is a integer overflow in media_tools/av_parsers.c in the hevc_parse_slice_segment function in GPAC 1.0.1 which results in a crash.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs987323

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gpac (PTS)stretch0.5.2-426-gc5ad4e4+dfsg5-3+deb9u1vulnerable
buster0.5.2-426-gc5ad4e4+dfsg5-5vulnerable
bullseye, sid1.0.1+dfsg1-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gpacsource(unstable)1.0.1+dfsg1-4987323

Notes

[buster] - gpac <no-dsa> (Minor issue)
https://github.com/gpac/gpac/commit/51cdb67ff7c5f1242ac58c5aa603ceaf1793b788
https://github.com/gpac/gpac/issues/1721

Search for package or bug name: Reporting problems