CVE-2021-30123

NameCVE-2021-30123
DescriptionFFmpeg <=4.3 contains a buffer overflow vulnerability in libavcodec through a crafted file that may lead to remote code execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)stretch7:3.2.14-1~deb9u1fixed
stretch (security)7:3.2.15-0+deb9u4fixed
buster7:4.1.6-1~deb10u1fixed
buster (security)7:4.1.8-0+deb10u1fixed
bullseye7:4.3.2-0+deb11u2fixed
bookworm, sid7:4.4-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsource(unstable)(not affected)

Notes

- ffmpeg <not-affected> (Only affects 4.4 development branches)
https://git.videolan.org/?p=ffmpeg.git;a=commitdiff;h=d6f293353c94c7ce200f6e0975ae3de49787f91f
https://trac.ffmpeg.org/ticket/8845
https://trac.ffmpeg.org/ticket/8863
CVE description is wrong, this landed in 4.4 only
Introduced in https://git.videolan.org/?p=ffmpeg.git;a=commitdiff;h=9c0beaf0d3bb72f6e83b3b155a598a9ec28c8468

Search for package or bug name: Reporting problems