CVE-2021-30164

NameCVE-2021-30164
DescriptionRedmine before 4.0.8 and 4.1.x before 4.1.2 allows attackers to bypass the add_issue_notes permission requirement by leveraging the Issues API.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2658-1
NVD severityhigh
Debian Bugs986800

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
redmine (PTS)stretch3.3.1-4+deb9u3vulnerable
stretch (security)3.3.1-4+deb9u5fixed
sid4.0.7-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
redminesourcestretch3.3.1-4+deb9u4DLA-2658-1
redminesource(unstable)(unfixed)986800

Notes

https://www.redmine.org/projects/redmine/repository/revisions/19975

Search for package or bug name: Reporting problems