CVE-2021-30458

NameCVE-2021-30458
DescriptionAn issue was discovered in Wikimedia Parsoid before 0.11.1 and 0.12.x before 0.12.2. An attacker can send crafted wikitext that Utils/WTUtils.php will transform by using a <meta> tag, bypassing sanitization steps, and potentially allowing for XSS.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mediawiki (PTS)stretch1:1.27.7-1~deb9u3fixed
stretch (security)1:1.27.7-1~deb9u9fixed
buster1:1.31.12-1~deb10u1fixed
buster (security)1:1.31.14-1~deb10u1fixed
bullseye, sid1:1.35.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mediawikisourcestretch(not affected)
mediawikisourcebuster(not affected)
mediawikisource(unstable)1:1.35.2-1

Notes

[buster] - mediawiki <not-affected> (Only applies to 1.35 and later)
[stretch] - mediawiki <not-affected> (Only applies to 1.35 and later)
https://phabricator.wikimedia.org/T279451

Search for package or bug name: Reporting problems