CVE-2021-30836

NameCVE-2021-30836
DescriptionAn out-of-bounds read was addressed with improved input validation. This issue is fixed in iOS 14.8 and iPadOS 14.8, tvOS 15, watchOS 8, iOS 15 and iPadOS 15. Processing a maliciously crafted audio file may disclose restricted memory.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-4975-1, DSA-4976-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
webkit2gtk (PTS)buster2.36.4-1~deb10u1fixed
buster (security)2.38.2-1~deb10u1fixed
bullseye2.36.7-1~deb11u1fixed
bullseye (security)2.38.2-1~deb11u1fixed
bookworm, sid2.38.2-1fixed
wpewebkit (PTS)bullseye2.36.7-1~deb11u1fixed
bullseye (security)2.38.2-1~deb11u1fixed
bookworm, sid2.38.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
webkit2gtksourcebuster2.32.4-1~deb10u1DSA-4975-1
webkit2gtksourcebullseye2.32.4-1~deb11u1DSA-4975-1
webkit2gtksource(unstable)2.32.4-1
wpewebkitsourcebullseye2.32.4-1~deb11u1DSA-4976-1
wpewebkitsource(unstable)2.32.4-1

Notes

[stretch] - webkit2gtk <ignored> (Not covered by security support in stretch)
https://webkitgtk.org/security/WSA-2021-0007.html

Search for package or bug name: Reporting problems