CVE-2021-30848

NameCVE-2021-30848
DescriptionA memory corruption issue was addressed with improved memory handling. This issue is fixed in iOS 14.8 and iPadOS 14.8, Safari 15, iOS 15 and iPadOS 15. Processing maliciously crafted web content may lead to code execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4975-1, DSA-4976-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
webkit2gtk (PTS)stretch2.18.6-1~deb9u1vulnerable
buster2.32.4-1~deb10u1fixed
buster (security)2.34.1-1~deb10u1fixed
bullseye2.32.4-1~deb11u1fixed
bullseye (security)2.34.1-1~deb11u1fixed
bookworm, sid2.34.2-1fixed
wpewebkit (PTS)bullseye2.32.4-1~deb11u1fixed
bullseye (security)2.34.1-1~deb11u1fixed
bookworm, sid2.34.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
webkit2gtksourcebuster2.32.4-1~deb10u1DSA-4975-1
webkit2gtksourcebullseye2.32.4-1~deb11u1DSA-4975-1
webkit2gtksource(unstable)2.32.4-1
wpewebkitsourcebullseye2.32.4-1~deb11u1DSA-4976-1
wpewebkitsource(unstable)2.32.4-1

Notes

[stretch] - webkit2gtk <ignored> (Not covered by security support in stretch)
https://webkitgtk.org/security/WSA-2021-0006.html

Search for package or bug name: Reporting problems