DescriptionGo before 1.14.14 and 1.15.x before 1.15.7 on Windows is vulnerable to Command Injection and remote code execution when using the "go get" command to fetch modules that make use of cgo (for example, cgo can execute a gcc program from an untrusted download).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
golang-1.11 (PTS)buster, buster (security)1.11.6-1+deb10u4vulnerable
golang-1.15 (PTS)bullseye1.15.15-1~deb11u2fixed
bookworm, sid1.15.15-5fixed
golang-1.7 (PTS)stretch1.7.4-2+deb9u1vulnerable
stretch (security)1.7.4-2+deb9u4vulnerable
golang-1.8 (PTS)stretch1.8.1-1+deb9u1vulnerable
stretch (security)1.8.1-1+deb9u4vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


[buster] - golang-1.11 <ignored> (Minor issue, only applies to inherently insecure setups)
[stretch] - golang-1.8 <ignored> (Minor issue, requires unsecure PATH and compiling a malicious dependency)
[stretch] - golang-1.7 <ignored> (Minor issue, requires unsecure PATH and compiling a malicious dependency) (master) (1.15.7)
Mainly an issue on Windows but as well for Unix users who have '.' listed
explicitly in PATH and running 'go get' outside of a module or with module
mode disabled.

Search for package or bug name: Reporting problems