CVE-2021-3115

NameCVE-2021-3115
DescriptionGo before 1.14.14 and 1.15.x before 1.15.7 on Windows is vulnerable to Command Injection and remote code execution when using the "go get" command to fetch modules that make use of cgo (for example, cgo can execute a gcc program from an untrusted download).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
golang-1.11 (PTS)buster1.11.6-1+deb10u3vulnerable
buster (security)1.11.6-1+deb10u4vulnerable
golang-1.15 (PTS)bullseye, sid1.15.8-4fixed
golang-1.7 (PTS)stretch1.7.4-2+deb9u1vulnerable
stretch (security)1.7.4-2+deb9u2vulnerable
golang-1.8 (PTS)stretch1.8.1-1+deb9u1vulnerable
stretch (security)1.8.1-1+deb9u2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
golang-1.11source(unstable)(unfixed)
golang-1.15source(unstable)1.15.7-1
golang-1.7source(unstable)(unfixed)
golang-1.8source(unstable)(unfixed)

Notes

https://github.com/golang/go/issues/43783
https://github.com/golang/go/commit/46e2e2e9d99925bbf724b12693c6d3e27a95d6a0 (master)
https://github.com/golang/go/commit/e8e7facfaa47bf21007c0a1c679debba52ec3ea0 (1.15.7)
Mainly an issue on Windows but as well for Unix users who have '.' listed
explicitly in PATH and running 'go get' outside of a module or with module
mode disabled.

Search for package or bug name: Reporting problems