CVE-2021-31155

NameCVE-2021-31155
DescriptionFailure to normalize the umask in please before 0.4 allows a local attacker to gain full root privileges if they are allowed to execute at least one command.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rust-pleaser (PTS)bullseye0.4.1-1fixed
bookworm, sid0.5.1-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
rust-pleasersource(unstable)0.4.1-1

Notes

https://www.openwall.com/lists/oss-security/2021/05/18/1

Search for package or bug name: Reporting problems