CVE-2021-3144

NameCVE-2021-3144
DescriptionIn SaltStack Salt before 3002.5, eauth tokens can be used once after expiration. (They might be used to run command against the salt master or minions.)
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2815-1
Debian Bugs983632

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
salt (PTS)buster, buster (security)2018.3.4+dfsg1-6+deb10u3fixed
bullseye (security), bullseye3002.6+dfsg1-4+deb11u1fixed
sid3004.1+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
saltsourcestretch2016.11.2+ds-1+deb9u7DLA-2815-1
saltsourcebuster2018.3.4+dfsg1-6+deb10u3
saltsource(unstable)3002.5+dfsg1-1983632

Notes

https://saltproject.io/security_announcements/active-saltstack-cve-release-2021-feb-25/
Introduced by: https://github.com/saltstack/salt/commit/b8e34e1f6f785bf00634ee561c89c30c45f4c689 (v2018.2)
Fixed by: https://github.com/saltstack/salt/commit/7c1d565465f78a7937f089857f3980045f27fd6e (v3002.3)

Search for package or bug name: Reporting problems