CVE-2021-3148

NameCVE-2021-3148
DescriptionAn issue was discovered in SaltStack Salt before 3002.5. Sending crafted web requests to the Salt API can result in salt.utils.thin.gen_thin() command injection because of different handling of single versus double quotes. This is related to salt/utils/thin.py.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs983632

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
salt (PTS)stretch2016.11.2+ds-1+deb9u4vulnerable
stretch (security)2016.11.2+ds-1+deb9u6vulnerable
buster, buster (security)2018.3.4+dfsg1-6+deb10u2vulnerable
bullseye, sid3002.6+dfsg1-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
saltsource(unstable)3002.5+dfsg1-1983632

Notes

https://saltproject.io/security_announcements/active-saltstack-cve-release-2021-feb-25/

Search for package or bug name: Reporting problems