CVE-2021-31566

NameCVE-2021-31566
DescriptionAn improper link resolution flaw can occur while extracting an archive leading to changing modes, times, access control lists, and flags of a file outside of the archive. An attacker may provide a malicious archive to a victim user, who would trigger this flaw when trying to extract the archive. A local attacker may use this flaw to gain more privileges in a system.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2987-1, DLA-3202-1
Debian Bugs1001990

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libarchive (PTS)buster3.3.3-4+deb10u1vulnerable
buster (security)3.3.3-4+deb10u3fixed
bullseye3.4.3-2+deb11u1fixed
bookworm3.6.2-1fixed
bookworm (security)3.6.2-1+deb12u1fixed
sid, trixie3.7.2-2.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libarchivesourcestretch3.2.2-2+deb9u3DLA-2987-1
libarchivesourcebuster3.3.3-4+deb10u2DLA-3202-1
libarchivesourcebullseye3.4.3-2+deb11u1
libarchivesource(unstable)3.5.2-11001990

Notes

https://github.com/libarchive/libarchive/issues/1566
https://github.com/libarchive/libarchive/commit/b41daecb5ccb4c8e3b2c53fd6147109fc12c3043 (v3.5.2)
https://github.com/libarchive/libarchive/commit/e2ad1a2c3064fa9eba6274b3641c4c1beed25c0b (v3.5.2)

Search for package or bug name: Reporting problems